Symptom #
When you launch the BPA Platform client it fails and the following error is produced:
Load Failure: The code expected does not match the one contained in the launcher
Cause #
This error can occur when an OEM uninstall did not remove all of the previous OEM data. This can lead to a mismatch of information when a license key check is performed and will prevent automatic login to BPA Platform.
Applies To #
The BPA Platform client machine.
Resolution #
To prevent this error from occurring two BPA Platform registry keys that encrypt the user’s login credentials will need to be recreated.
- Enter the Registry Editor and navigate to the following location:
HKEY_CURRENT_USER\Software\Orbis Software\BPA Platform - Export the BPA Platform folder from the registry for back up purposes.
- Rename the ID1 and ID2 registry keys, i.e. ID1 (old)and ID2 (old). Renaming these keys will cause them to be recreated when BPA Platform is loaded.
- Launch BPA Platform. You will be then prompted to provide valid login credentials to enable access.
Figure 1. Location of the ID1 and ID2 registry keys.