Why are my SAP Business One UDT, UDF, and UDOs not Triggering my Tasks?

Summary

Your BPA Platform solution makes use of the SAP Business One Integration Tool Pack, specifically, the SAP Business One Event Agent.

You’ve added user-defined tables (UDT), user-defined fields (UDF), and/or user-defined objects (UDO) to your SAP Business One installation.

You’ve created a task which triggers on the new tables, fields, or objects.

Your tasks fail to trigger.

Cause

Once the new objects are added to SAP Business One, they are available in the SAP Business One Event step configuration window for you to create triggers against:
SAP Business One Event Step Configuration - UDO

When you check the XML received by the SAP Business One Event Agent, you can see the UDT, UDF, and UDOs being sent. However, you’ll also notice the History and Trigger elements are not populated.

This is because when creating the UDTs, UDFs, or UDOs you must enable them to log history. Without a history log, the Event Agent is unable to trigger.

Resolution

You enable the history logs in the User-Defined Object Registration window in SAP Business One itself.