Symptom #
When you create a new connection (or refresh the schemas on an existing connection) you receive the following error:
Error 5-5 (- access is denied) connecting to the DI API.
Cause #
The DI API is not updating a set of temporary files correctly.
When a connection is created (or schemas refreshed) the TaskCentre tools for SAP Business One connector makes use of the DI API to list user defined objects (tables, views) in the SAP database.
The DI API in turn makes use of C:\WINDOWS\TEMP\SM_OBS_DLL to call the SAP server.
Where SM_OBS_DLL is of the incorrect version, the error occurs.
Applies To #
TaskCentre Tools for SAP Business One.
Resolution #
- Go to C:\WINDOWS\TEMP on the server where the TaskCentre tools for SAP Business One connector web service is installed.
- Delete the SM_OBS_DLL directory.
- From the main menu with TaskCentre go to Manage > Tools > SAP Business One > SAP Business One Connector.
- Refresh the schemas.
- This will then cause the DI API to get the temporary files correctly.