Symptom #
Within the global configuration of the Microsoft Dynamics CRM Connector tool, when trying to create a new connection to a Microsoft Dynamics CRM platform an error similar to the following is received:
System.ArgumentException: The selected Deployment Type does not match the available endpoint
or
System.ServiceModel.Security.SecurityAccessDeniedException: Access is denied
Cause #
The account being used in the MS Dynamics CRM Connector Tool connection settings, has insufficient permissions to access the Dynamics CRM discovery endpoint, the organisations in Dynamics CRM, or both.
The account being used in the tool global configuration has insufficient permissions to access the locations required to create a new connection.
Resolution #
Ensure the MS Dynamics CRM account, required by TaskCentre,has been configured correctly to enable access to the discovery endpoint and/or the required organisations in MS Dynamics CRM.
This account, when supplied within the Authentication tab of a new global connection, will then allow the configuration to successfully connect.
The new CRM environment will then be added to the list of connections for use by the connector tool at task level.