Symptom #
A connection to Office 365 has been created using the Send Email (SMTP) global configuration but at task runtime the following error appears in the event log:
TLS Session Negotiation Failed. Connection Aborted
If you attempt to test the connection the following message is received:
SMTP server connection test failed: Connection has been lost
Cause #
This issue has been caused by a change identified in the third party software Office 365. This is not an issue caused by TaskCentre.
Solution #
Upgrade the installation of TaskCentre to version 4.7 or higher – updated TLS components are present to provide a fix.
For further reference material please see the following knowledgebase article:
Using Office 365 SMTP hosted services in conjunction with TaskCentre
Workaround #
For users who are unable to upgrade to 4.7 or higher: relay mail to Office 365 using Internet Information Services (IIS) 6.0 and the SMTP Virtual Server.
On the TaskCentre Server machine install Web Server (IIS) and enable the SMTP Server. Configure IIS and TaskCentre as below.
IIS SMTP Virtual Server #
Enter the properties of the SMTP Virtual Server.
Access Tab – Relay #
Select Relay and Add the local server IP address.
Delivery Tab – Outbound Security #
Select Outbound Security and select Basic Authentication. Enter the credentials of the Office 365 account that emails will be sent from. Tick the box TLS Encryption.
Delivery Tab – Outbound Connections #
Select Outbound Connections and set the TCP Port number to 587.
Delivery Tab – Advanced #
Select Advanced and set the Smart Host to smtp.office365.com.
TaskCentre – Send Email (SMTP) – Global Configuration #
Enter the Send Email (SMTP) global configuration.
Main Tab #
Set the Server Address to localhost.
Advanced Tab #
Tick the box Use Secure SMTP if available. Ensure the Port Number is set to 25.
TaskCentre – Send Email (SMTP) – Step Configuration #
When configuring the Send Email (SMTP) step, ensure the From address uses the Office 365 account set within IIS.