Symptom #
When using the Quotation object to perform an Update operation, an error similar to the following is received:
This entry already exists in the following table (ODBC -2035)
Cause #
This is a known issue, specific to the Sales Quotation and Purchase Quotation objects.
Solution #
- Remove the files oQuotationsRequest.xslt and oQuotationsResponse.xslt from the folder:
c:\inetpub\wwwroot\CommunicatorWS\Schemas\ServiceTranslation - Edit the oQuotations.xml file in c:\inetpub\wwwroot\CommunicatorWS\Schemas and remove the ServiceName and AllDataOnUpdate attributes from the first tag.
- Within TaskCentre, refresh the schemas for the global connection.
- Edit the task step and re-select the Quotation object.
- Save all changes made within the task.