Error Message: Unable to establish a connection to the Server. Please check the connection details and Server availability
Table of Contents
Symptom
When you attempt to login to the TaskCentre client you receive the following error message:
Unable to establish a connection to the Server. Please check the connection details and Server availability.
Cause
Multiple causes; the two most common being:
- The TaskCentre server service is not running
- The TaskCentre server service is running but is not accepting connections
Applies To
TaskCentre Server
Resolution
There are a number of resolutions to this error; therefore the key is to try each one in turn.
- Check the TaskCentre server service is running. If the service is in a stopped state, you can start it by typing in the following from a command prompt: NET START TCServer
- Confirm the service is accepting connections by typing in the following from a command prompt on the TaskCentre server: telnet localhost 4223
If it connects successfully you will see a blank screen with a flashing horizontal cursor.If you receive the error “Could not open connection to the host, on port 4223: Connect failed” you should upgrade to the most recent build of TaskCentre as this will often resolve the issue. As a minimum you should be running TaskCentre 4.6.