OBServerDLL.dll version is older than the DI API version – Error code -8003

Symptom

Creating a connection fails with the error:

An error has occurred while processing connection 'CONNECTION_NAME': Failed to Connect to DIAPI Server: 
SAP B1 Error Response - OBServerDLL.dll version is older than the DI API version (Error Code: -8003)

Cause

This error occurs when there is a version miss-match between the SBOCommon database and the Company database.

Solution

To resolve this problem requires a reinstall of the DI API.