Symptom
When you call an operation in the SalesLogix Connector step it fails with the following error message:
Could not find file 'C:\Windows\TEMP\xxxxxxxx.dll'
Cause
When the SalesLogix Connector communicates with the SalesLogix Connector web service, the web service attempts to create a temporary file in the ‘C:\Windows\TEMP’ directory. In this case the account that the SLX connector web service runs under has insufficient permission to create the file.
Resolution
Give the account that the SLX Connector web service runs under (Normally this is the ‘NETWORK SERVICE account) full permissions to the ‘C:\Windows\TEMP’ directory.