SAGE 50 Accounts 2012 – ODBC query fails with “DAO error column not found ODBC — call failed”

Symptom

When you query data within the Database Query (ODBC) tool you may receive the following error:

DAO error column not found ODBC -- call failed

Cause

The error is due to changes that have been made to the “Sage 50 v18 ODBC driver” in Sage 50 Accounts 2012 update 3. The change causes queries that make use of Data Access Objects to fail.

Applies To

TaskCentre: all versions where a task with an ODBC step connects to the “Sage 50 v18 ODBC driver” that ships with Sage 50 Accounts 2012 update 3.

Additional

Data Access Objects (DAO) is a data access library that ships with Windows. It provides additional functionality for ODBC drivers. For example, allowing the use of a current date function in an ODBC query where the ODBC driver does not natively support this.

Within TaskCentre you can make use of DAO by deselecting the “use pass-through” option under the connection tab of the connection’s global configuration.

Resolution

An ODBC hotfix has been supplied by Sage that resolves this issue. At the time of writing this can be accessed by logging in to https://support.sage.co.uk, selecting the “Downloads Home” page and downloading the “Sage 50 Accounts 2012 – ODBC Hotfix”.

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