Sage 200 Connector Tool – Error: Could not load file or assembly.

Symptom

When creating a connection to Sage 200 using the Sage 200 connector tool global configuration, an error message similar to the following:

Could not load file or assembly Sage.Accounting.Financials, Version = 16.0.0.0

The error format being:

Could not load file or assembly [NAME], [VERSION]

Where NAME is a Sage assembly and VERSION is the assembly version.

Cause

A version of the connector tool is being used with an unsupported version of Sage 200.

This error may occur if for example Sage 200 has been upgraded, i.e. from 2011 to 2013. A newer release of the connector tool which supports the later version of Sage would also be required.

Resolution

Download the release of the Sage 200 connector tool that matches your version of Sage 200.

The download can be obtained from Community -> Partner Area

  • Sage 200 2013 R2 – Download Sage 200 Connector Tool for 2013 R2
  • Sage 200 2013 R1 – Download Sage 200 Connector Tool for 2013 R1
  • Sage 200 2011 – Download Sage 200 Connector Tool for 2011
  • Sage 2010 – Download Sage 200 Connector Tool for 2010
Sage 200 Integration Brochure

Sage 200 Integration Brochure

Learn how integrating Sage 200 with on premise or cloud-based business software removes the risk of costly errors and improves the visibility of critical data.

Download Brochure