Skip to content

Knowledge Base

Business Process Automation Platform

Configuring TaskCentre to use a Gmail SMTP account: Error – The message received was unexpected or badly formatted

Symptom

When configuring a Send Email (SMTP) global connection to use a Gmail SMTP account, the following error is received when attempting to test the connection:

SMTP server connection test failed: The message received was unexpected or badly formatted

Error Message

Cause

RC4 based cipher suites in use by TaskCentre are no longer supported by ‘smtp.gmail.com’.

Solution

The changes implemented in Gmail are supported in TaskCentre 4.7 and higher.